路线制作教程


概述                                  1 
本教程以创建一条实例路线为例，简要介绍一下如何使用Route Geometry Extractor和Route Editor两种编辑器来制作自己的路线。

打开游戏编辑器。执行菜单命令“开始->程序->Microsoft Games->Train Simulator->Train Simulator Editors & Tools”，将进入图1-1所示界面。
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首先应使用Route Geometry Extractor 在地球上圈出一块地域（此地域可以是任意大小和形状），然后用Route Editor在此地域上放置所需的轨道、车站、山川、树木等现实世界中的物体，并添加各种辅助设施和游戏对象，这样就能在任务编辑器（Activity Editor）中制作任务了。

　　在后面的第2章和第3章里，本教程会按步骤讲解Route Geometry Extractor和Route Editor的用法。

使用Route Geometry Extractor (RGE)         2 
您可以使用Route Geometry Extractor（RGE）工具创建新的MSTS路线，或修改任何已有路线的terrain tiles（地形方块），terrain tiles（地形方块）是Route Editor用来在上面构造路线所需的地面。缺省情况下，RGE工具生成平坦的地形（海拔高度为1米）。

提取地形后，您就可以使用Route Editor来处理地形、添加轨道以及诸如建筑物、车站、信号机、树木、山川及公路等物体。

1 创建新的路线　　　　　　　　　　　　　　　　　　　　　　　

使用RGE创建新的路线涉及到两个步骤：

●指定新路线的名称和基本特征

●指定需要占据的具体地形区域
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1.1 指定路线名称、特征和速限

1. 在RGE的窗口中，执行菜单命令“File->New Route…”，将打开Create New Route（创建新路线）对话框，如图2所示。
　　2. 在Route Name（路线名称）栏中，输入路线的名称和所存放的文件夹的名称。这里，我们全部输入“My Route”。另外，单击Edit Description（编辑描述）按钮，还可以输入与路线有关的文字描述。

3. 在Route Features（路线特征）栏中，如果选中了Electrified track（电气化线路）复选框，则表示路线是电气化的，在Electrified cable height in metres栏中，可输入接触网的高度（单位：米）。

Terrain detail scaling factor栏中输入的数值代表地形方块的大小（就是在Route Editor中看到的蓝色网格）。

上面两个参数均使用默认值。

4. 对话框的最下面是Route Speed Limits（路线速度限制）栏。其中，Route restricted speed limit用来设定受限速度；Route maximum speed limit用来设定最高速度限制。如果希望用公里作为速限单位，取消对复选框Speed limit values are MPH（KPH otherwise）的选择即可。

5. 请按图2所示进行设置。最后按OK按钮退出，系统会弹出提示对话框（图3），说明已
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在游戏目录中创建了存放路线数据的文件夹，本教程中为：“d:\Microsoft Games\Train Simulator\Routes\My Route”。

1.2 指定terrain area（地形区域）　　　　　　　　　

1. 执行菜单命令“File->Select Route…”，会弹出Select a Route（选择路线）对话框，上面有一个选择可用路线的下拉列表框，如图2-3所示。
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选择刚才创建的路线My Route，单击OK退出。

2. 执行菜单命令“File->New Quad-Tree”，此时除了在窗口状态栏的左边会出现“[My Route Normal Terrain]”字样外，其他没有任何变化，因为Quad-Tree仍然是空白的： Quad-Tree是RGE工具用来布置terrain tile（地形方块）的区域（是一种由大到小的方格组成的树状结构）。

3. 在窗口中的地图上您所希望的区域单击右键，在弹出的快捷菜单中选择Zoom Region（放大区域）命令，此时地图会以所选区域为中心放大，想进一步放大的话，重复Zoom Region命令，或选择快捷菜单中的Zoom Window In命令。

放大的程度以适当显示所选区域为准，这时，会看到用来指示现实世界中真实路线的红线。

提示：为了避免在放大时丢失所选区域，请注意当鼠标移动时窗口底部状态栏所显示的经度和纬度，当看不到所选区域时，可通过调整水平和垂直滚动条并借助经纬度来修正。

4. 在您希望的路线所占据的地图区域上用鼠标拖出一个矩形。在矩形的内部单击鼠标，选择Add All Selection Tiles命令，此时，在所选矩形中会出现很多黑色的方格（这就是Quad-Tree），最小的方格代表大约两公里见方的terrain tiles（地形方块），如图2-4所示。

您可以重复上面的过程来增大黑色小方格所占据的区域，如果选择区域比您预想的要大，没关系，稍后我们会把不必要的方格删掉。
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5. 为了更精确的选择，请进一步放大所选区域。在黑色小方格区域内用鼠标拖出一个矩形，在矩形内单击鼠标右键，选择菜单命令“Toggle Populated State”，这时，所选矩形内的小方格会变成蓝色，表明此区域就是最终要在Route Editor中使用的地形区域，如图2－5所示。

为了得到不规则的形状，可重复上面的步骤进行多次选择，也可以用鼠标单独选择一个小方格执行Toggle Populated State命令。

另外，如果某一次选择后您觉得不满意，可以再执行一下Toggle Populated State，就会取消刚才的选择。

6. 执行菜单命令“Edit->Minimize Quad-Tree”，当系统提示“This will remove empty quad-tree nodes. Continue?”，选择“是”，这样没有选中的小方格（没有变蓝色的）就会被删掉，以减少路线文件的容量。删减后的区域形状如图2-6所示。
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7. 执行菜单命令“File->Save Quad-Tree”以保存所做的选择。

　　8. 执行菜单命令“Edit->Generate Flagged Tiles”，会弹出图2-7所示的对话框，指出要生成的方块的数量和已标记的方块数量，并询问是否进行生成。选择“是”。
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接着，您就会在状态栏中看到，RGE正一个接一个地创建地形方块。此过程需要进行几分钟的时间（与生成的方块数量有关）。

9. 生成完毕后，用鼠标在希望的路线起点单击右键，在快捷菜单中选择命令“Route Editor Start Tile”，随后的对话框会提示“Route editor start tile updated”（路线编辑器起点已更新）。这里的起点就是在打开Route Editor后摄像机视角的初始位置。

1.3 地形区域创建完毕

OK！现在已生成了路线地形区域，在第3章，我们会进一步了解如何使用Route Editor创建真实的路线及场景。

2 编辑已有路线 　　　　　　　　　　　　　　　　　　　　　　　

除了创建新路线外，您还可以使用Route Geometry Extractor（RGE）在已有路线上进行添加地块和删除地块等工作，也可以对路线参数进行修改。

2.1 打开已有路线

1. 执行菜单命令“File->Select Route…”，会弹出Select a Route（选择路线）对话框，上面有一个选择可用路线的下拉列表框，如图2-8所示。
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选择需要编辑的路线，如：My Route，单击OK退出。
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2. 执行菜单命令“File->Load Quad-Tree”，此时，地图上会出现该路线已选择的区域（用蓝色方格表示），如果蓝色方格太小看不清的话，用“1.2指定terrain area”中的方法进行放大显示。

2.2 编辑路线数据

1. 打开路线后，执行菜单命令“Edit->Route Values…”，会弹出图2-9所示Edit Route Values对话框。

2. 这个对话框与图2-1所示的对话框功能一样，只不过是不能修改路线存放的文件夹名称。在这里，可以对已有路线的参数进行修改编辑。

2.3 删除单一地形方块

1. 在需要删除的蓝色方格（代表单一地形方块）上单击鼠标右键，在弹出的快捷菜单中选择“Delete Tiles”命令，系统会弹出图2-10所示对话框，如果括号中的提示是“1 tiles”，则单击“是”确认删除；如果提示多于1个tiles，则选择“否”，退出后重来一次。
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当选择“是”删除地块后，原来的蓝色方格变成了黑框方格，而且RGE会自动删除相关文件并将此方格进行un-flag（取消标记）操作。

也可以通过另一种方法删除所选地块，就是在快捷菜单中选择“Toggle Populated State”命令而不是“Delete Tiles”，这种方法与前一种方法的区别是，不会删除相关的文件，而只是对所选方格进行un-flag（取消标记）操作。

2.3 删除大片的地形方块

如果要对大片的地块进行删除，只需用鼠标圈出一个矩形进行选择即可，其余方法与删除单一地块的方法一致，但最后要执行一下“Edit”菜单的“Minimize Quad-Tree”命令，以精简路线文件的容量。

记住：无论删除单一地块还是大片地块，在删除完后，要执行“File”菜单的“Save Quad-Tree”命令进行保存，并且按照“1.2指定terrain area”中第9步的方法，重新定义一下路线起点。

2.4 增加地形方块

您还可以按照“1.2指定terrain area”中第4到9步的方法，扩展已有的蓝色方格选择区域，这里不再赘述。

使用Route Editor                              3 
上一章中我们学习了用Route Geometry Extractor制作地形区域的方法，有了地形区域就像有了画布一样，我们就可以借助Route Editor这支“画笔”，在这块“画布”上挥毫泼墨、尽情发挥来建造自己的铁路线了。

1 Route Editor窗口及工具　　　　　　　　　　　　　　     　　
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    在编辑完Route Geometry Editor后应先退出Editors & Tools，再重新打开图1-1的编辑器主窗口，选择第一个编辑器“Route Editor”（路线编辑器），系统会弹出“Select a route”（选择路线）对话框（见图3-1），每当我们在Route Geometry Extractor中创建了新的地形区域后，都会在这个对话框中选到所建的路线名称，这里我们选择已建好地形区域的“My Route”路线，单击“OK”继续，进入Route Editor编辑器。

Route Editor编辑器由一个显示三维地形的主窗口和若干小的工具窗口组成。在铺设轨道、放置物体前要先熟悉这些窗口的主要功能。
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1.1 主窗口

主窗口如图3-2所示。它初始显示的地方就是在第2章中设置的Route Editor Start Tile（路线编辑器起点地块），这时的地形是使用默认地表材质的平坦地形。我们首先要了解怎样辨别方向，并且怎样移动摄像机视角。

1. 在主窗口的正上方有一个红色的刻度标尺，标尺的中间指针指向就是视角所朝的方向：0、90、180、270分别对应北、东、南、西。标尺下方的Lat和Lon分别指明了当前摄像机视角所在地的纬度和经度。

2. 要在窗口中移动和旋转摄像机视角，请使用以下方法：

● 向前移动   ↑键

● 向后移动   ↓键

● 向左移动   ←键

● 向右移动   →键

● 向上移动   Ctrl+↑键

● 向下移动   Ctrl+↓键

· 按以上键时，同时按住Shift键，可加快移动速度

· 按以上键时，同时按住End键，可放慢移动速度

· 按住鼠标右键并移动鼠标，可以以任何角度旋转摄像机视角

3. 请注意在主窗口的状态栏中有这样的提示：Camera terrain collision: ON，这时，按键盘的“/”键，可在ON和OFF之间进行切换。当Camera terrain collision（摄像机地形碰撞）为ON时，向下移动摄像机视角碰到地面时，就不会再继续下移；当Camera terrain collision为OFF时，摄像机下移碰到地面时会穿过地面移到地下，这时，看到的是一片白色，而不是绿色地面，如图3-3所示。
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当出现这种情况时，只要在按一下“/”键，就可以回到地面。

4. 另外，为了能看出路线在一天中不同时间里的视觉效果，可以按“+”键和“-”键来改变太阳和月亮的位置，例如，将视角刻度对准90，您就可以看到太阳从东方升起了。

1.2 工具窗口

Route Geometry Extractor提供了若干工具窗口，这里先简要介绍一下几个常用的工具窗口的功能，后面再详细讲解如何结合不同的工具窗口来放置物体和修改地形。

1. Camera（摄像机）
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Camera窗口显示了当前摄像机所处的位置，如图3-4所示。

x、y、z分别代表了南北方向、高度方向和东西方向上的坐标值；long是当前位置的经度，alt是高度（单位：米），lat是纬度；tile x和tile z分别是当前地块在东西方向和南北方向上的编号。

以上参数可以修改，修改后按下“Jump”按钮，摄像机就会“跳”到相应的位置上了。

另外，窗口上有一个微调按钮“detail: x”，它代表当前主窗口中物体的显示级别（显示级别是所有物体都有的属性，可以修改），相当于图层的概念，x缺省是10。当按动微调按钮增大或减小detail值时，只有显示级别小于或等于当前detail值的物体才能被显示，否则会消失（实际上还存在，只是不显示罢了）。
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2. Placement（放置）

Placement工具窗口（图3-4所示）用于选择能够放置在地面上的所有物体对象。其中：

“More…”按钮用来打开Object Selector（物体选择）对话框；当选择了某一物体后，最上面的显示框会显示当前物体的名称；中间的列表框能列出最近选择的5个物体对象；窗口左边的x、y、z是放置物体时鼠标所在地的坐标，它们与Camera窗口中的x、y、z含义一样。
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另外，窗口左下方有一个grid复选框，复选框下面有一个可修改的参数，如果选中了grid复选框，当用鼠标放置物体时，会自动以该参数定义的网格大小进行捕捉。

3. Terrain（地形）

Terrain工具窗口（图3-5所示）用来设置生成山坡、路堤、湖泊、河流等起伏地形时所用的参数。
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embankment参数表示高于地平面的坡地、路堤等地形的斜坡角度；cutting参数与embankment正好相反，它表示低于地平面的洼地的斜坡角度；width参数表示当铺设的轨道、公路高于或低于地平面时，按下“Y”键生成路堤的宽度（单位：米）。

4. Object（物体）

Object窗口用于显示当前所放物体的坐标位置以及高度。另外“Reset rotation”（复位旋转）按钮可以将已旋转的物体恢复到旋转前的状态。

5. Mode（模式）

Mode窗口是一个浮动的工具栏，用它可以选择各种操作模式，详细说明如下：

按钮         快捷键           功能
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               F2           选择物体
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               F3           移动物体
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               F4           旋转物体
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               F5           放置物体
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               F6           编辑物体的属性
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               F7           修改地形材质
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               F8           在材质上画

[image: image27.jpg]erid:OFF Canera terrain 0N Telephone - CENTER




               F9           改变地形高度

到此为止，我们已经了解了Route Editor各主要窗口的功能，接下来，就要进入激动人心的实战阶段了，下一部分我们将以一个实例来迈出路线制作的第一步。

2 实例制作              　　　　　　　　　　　　　　     　　
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本教程将创建一个如图3-8所示的路线。

2.1 铺设轨道

[image: image29.jpg]5 4706 e ST

Snap to grid:OFF Canera terrain



考虑到轨道是一条路线最基本的元素，所以建议在放置其他物体之前，首先铺设路线中所有的轨道。

1. 如果您的路线是电气化的，那么在铺设轨道前，现确定电气化的类型。执行菜单命令“Route->Properties”，会打开Route properties（路线属性）对话框（图3-9）。

在Unit（单位）栏中选择Metric（公制）。

在Electrification（电气化）栏中有三个选项：选中Not electrified表示此路线不能行驶电力机车；选中Overhead wires时表示所建线路具有架空的接触网，可供电力机车行驶；当选择Third rail（第三方铁路）选项时，所建路线不会有接触网，但可以行使电力机车。

另外，Electrification栏中，Wire height参数是接触网的高度（单位：米）；Voltage参数是接触网电压（单位：伏）。

请按图3-9设置以上参数和选项。
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2. 单击Mode窗口中的按钮；在Placement窗口中单“More…”按钮，打开Object Selector（物体选择）对话框（如图3-10）所示。

Object class（物体分类）下拉列表框中是当前路线可用的物体种类；当在Object class选中了某一种类后，Objects（物体）列表框会列出该种类所包含的所有物体；而选中Show thumbnails复选框时，Object列表框会同时显示每一种物体的缩略图。
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OK，我们选择Track Sections种类下的A1t500mstrt.s。Track Sections种类包含了路线中可用的所有轨道类型；A1t500mstrt.s含义是：A1t代表单线，500m是长度为500米，strt表示直轨。

选择后单击Ok退出。

3. 此时，主窗口中鼠标的指针变成了白色的十字形。在地面上单击鼠标，我们刚才选择的轨道就铺上了（如图3-11所示）。这时，轨道成线条框架状显示，说明当前物体处于选择状态。

4. 当鼠标指针还是白色十字时，单击刚才放上去的轨道的一端，则当前选择的500米直轨会接着刚才的轨道继续铺设，而且能自动与原有轨道“咬合”。另外，原先铺设的轨道会变成非选择状态，即显示出其真实外表，而后来铺设的轨道则处于选择状态。见图3-12。

注：如果物体处于选择状态时，按F2键或按Mode窗口中的选择按钮，此时鼠标在主窗口中为箭头形状，在物体外的地面上单击鼠标，会使物体退出选择模式，回到正常显示状态。
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5. 向北（0方向）移动摄像机视角到第一条直轨的另一端，按照前面的方法选择A1tPnt10dLft.s轨道，它代表10度左分道岔。用鼠标在直轨的一端单击，一个道岔就接到了500米直轨上，如果这时按“T”键，道岔的三个端口会与直轨切换连接组合。按“T”键调整到图3-13所示位置。
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在Object Selector对话框中选择A1tEndPnt10dLft.s，用十字形鼠标在图3-13中红色箭头所指的地方单击，会铺设一条弯轨，不过它仍然弯向左边，而我们希望由道岔分出去的是另一条平行的直轨，这时按下“T”键，将弯轨转个向。现在，弯轨的另一端就与原来的直轨平行了（如图3-14所示）。

注：如果选择的是右分道岔A1tPnt10dRgt.s的话，与之配合使用的弯轨是A1tEndPnt10dRgt.s。

现在道岔的直轨部分与弯轨部分没有平齐，让我们选择10米的直轨A1t10mstrt.s在图3-14红色箭头所指的地方连续铺设两段，这样，我们的第一条道岔就完工了。见下页图3-15。
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6. 现在，我们开始接着道岔铺设复线（一条正线，一条侧线）。按前面讲述的方法选择250米的复线直轨A2t250mstrt.s，接着图3-15黄色箭头处铺设。如果出现了图3-16左边的情况，按一下“T”键就可以纠正。
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    7. 移动视角到250米复线的尽头，选择A1tEndPnt10dRgt.s，在左边的侧线上单击鼠标铺设一条弯轨（如图3-17所示）。再选择A1tPnt10dRgt.s，在弯轨的另一端单击鼠标，铺设一个右分道岔，按两次“T”键调整到图3-18所示位置。
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这时，您会发现道岔与正线之间还有一个缺口，我们再用两条10米的直轨（A1t10mstrt.s）将它补齐即可（见图3-19）。OK！由一条正线和一条侧线组成的简易车站路线就做好了，对了，不要忘记随时保存（选择Route菜单中的Save命令），建一条路线可不容易呀！
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8. 接下来再铺设两段500米直轨（A1t500mstrt.s），然后把视角移动到直轨的尽头，开始铺设曲线轨道。选择A1t500r20d.s，它表示半径为500米、圆心角为20度的曲线轨道（如图3-20），连续铺设9条这样的曲线轨道，也就是说，我们的路线来了个180度大转弯。

9. 按下面的顺序和数量铺设剩余的轨道：

2条500米直轨（A1t500mstrt.s）

1个左分道岔（包含1×A1tPnt10dLft.s，1×A1tEndPnt10dLft.s，2×A1t10mstrt.s）

1条250米直轨复线（A2t250mstrt.s）

1个右分道岔（包含1×A1tPnt10dRgt.s，1×A1tEndPnt10dRgt.s，2×A1t10mstrt.s）

2条500米直轨（A1t500mstrt.s）

到此，我们路线的轨道部分就完成了，后面的工作就是添加辅助的动态物体（如：信号灯）、静态物体（如：建筑物、桥梁、公路）及虚拟交互式物体（如：汽车生成器、站台）等。

2.2 添加信号机（介绍如何移动物体）

信号机是一条路线必不可少的物体对象，有了它，所编辑的任务才能更真实、更复杂、更有趣。下面的步骤介绍如何给我们前面所建的车站添加出站信号机。
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1. 确认已选中了Mode窗口中的       放置物体按钮，在Placement窗口种单击More按钮，打开Object Selector对话框。

2. 选择Track Objects类别中的信号机Japan 3 Light Signal（Left），将摄像机视角移动到图3-21所示位置，在红色箭头所指处单击鼠标，此时，一个信号机和一个红色立体箭头出现在轨道中央（如图3-22所示）。
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红色立体箭头所指方向就是信号机所作用的方向，本例中，信号机作用于侧线的出站方向。现在，信号机位于轨道的中央，需要调整一下位置。
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首先选择信号机，接着单击Mode窗口中的移动物体按钮，或按F3键，此时，鼠标指针变成十字方向箭头，物体处于被移动状态。按数字键盘上的“4”和“6”键，可以将信号机左右移动，这里，我们把它移到路基的最左边就行了。

注：上面移动物体的方法是小范围的移动，如果要进行比较大的移动，在物体处于移动状态时，用鼠标直接拖动物体即可；如果不希望物体移动到地面下边的话，移动时按着“H”键就行了，或者是移动后，按一下“H”键。另外，数字键盘上的“8”和“2”键用于上下移动。

2.3 修建公路立交桥

现实世界中很多公路跨越铁道时，都是用立交桥，这里，我们也式着做一个简易的立交桥。

    1. 首先要找一座合适的桥。因为我们创建路线时选择的是缺省模板（图2-1种的Source template），所以Object Selector对话框中可供选择的物体种类很少，那么，就需要从外部添加我们所需要的物体。添加的物体可以用其它路线的，也可以自己用3D软件制作，但添加方法都是一样的。下面我们就从别的路线借用一座桥梁。

2. 退出Route Editor（路线编辑器），打开“资源管理器”或“我的电脑”，进入游戏目录“Train Simulator\ROUTES\JAPAN2”，将“Shapes“文件夹中的“JP1_RoadBridge_HiFence.s”和“JP1_RoadBridge_HiFence.sd”两个造型文件复制到“Train Simulator\ROUTES\My Route”中的Shapes文件夹内；再将“Train Simulator\ROUTES\JAPAN2”中“Textures“文件夹中的“JP1_RoadBridge_HiFence.ace”和“JP1straightroad.ace”两个贴图文件复制到“My Route”中的“Textures”内。用写字板打开“JAPAN2”中的“hisatsu.ref”文件，找到如下几行文字：

Static (


FileName ( JP1_RoadBridge_HiFence.s )


Shadow ( DYNAMIC )


Class ( "Bridges" )


Align ( None )


Description ( JP1_RoadBridge_HiFence )

)
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将这些文字添加到“My Route”文件夹中“My Route.ref”文件的最后，并保存此文件。再次打开Route Editor，并进入My Route路线，此时，在Object Selector对话框中就能找到新增的种类“Bridges”及其所属的桥梁物体“JP1_RoadBridge_HiFence”了（如图3-23所示）。

注：往路线中添加任何其它物体时，方法同上，就是要将该物体的*.s和*.sd文件，以及物体用到的*.ace贴图文件复制到指定位置，另外还需要往路线的*.ref文件中添加对该物体的描述。

3. 将摄像机视角移动到一开始所铺设的直轨附近。选择刚才添加的桥梁，用鼠标单击铁轨中央，一座桥梁便架设在铁轨上方。

现在的桥看上去有点矮，我们需要将它升高。选择桥梁，单击Mode窗口中的移动物体按钮（或按F3键），按小键盘上的“8”键，将桥梁慢慢升高，直到合适的高度。

现在的效果如图3-24所示。
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4. 现在要在桥的两边连接上下桥的公路。

在Object Selector对话框中选择Road Section类别下的JP2Rd100mstrt.s，这是一条100米长的直行公路。单击Mode窗口中的放置物体按钮（或按F5键），将所选公路铺在地面上。
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接着用鼠标单击按钮，这时可以对公路进行旋转操作。按小键盘上的“4”和“6”可以分别进行逆时针旋转和顺时针旋转。
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注：物体处于旋转操作状态时，用小键盘上的“4”和“6”键可以对物体进行水平方向的逆时针旋转和顺时针旋转操作；用小键盘上的“2”和“8”可以对物体进行上下方向的逆时针和顺时针旋转。如果感觉旋转效果不是太好，可以按Object窗口中的Reset rotation按钮进行复位。

通过上下左右移动和水平方向的旋转将公路移动到图3-25所示位置。如果不太好移动时，在移动时请按住End键进行微调。
现在需要制作一条上坡的公路，因此需要把这条公路旋转一定的角度。选中公路，再按下旋转按钮，按小键盘上的“8”键（或者同时按住End键）将公路旋转，直到公路的另一端与地面接触（如图3-26所示）。

5. 这时，还需要为公路添加路基，这就用到了Terrain窗口中的地形修改功能。

首先选择公路，在Terrain窗口中，把Width参数设为9（参数含义请参阅第10页中3.Terrain中的解释）。这时，按下“Y”键，效果出现了！在公路的下面自动生成了路基（见图3-27）。另外，如果Width参数设置过大，公路路基将会掩盖铁轨，这时，选中铁轨再按“Y”键就可以[image: image50.jpg]Station name

Secondary (platform) name

a0l

‘When Iooking dovn the platfom (from star to end), the
Platform s actually on this ide

I Leftside ' Right side

I Disble this platfonu by defult
(This canbe overidden in the Activity Editor)

Ptform i, it

Mimtes: [3 Saconds:

Bumber of passengers waitng at platform
=




调整过来。

    按照相同的步骤和方法，为桥的另一端添加公路和路基（图3-28），另外，还可以再接着添加公路（方法同铺设铁轨一样，公路也会自动“咬合”的）。

6. 在游戏中我们会看到，公路上有川流不息的车辆，这是通过在路线中的公路上添加Car Spawner（汽车生成器）来实现的。
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在Object Selector对话框中选择<Interactive Objects>类中的Car Spawner（在其它路线中有可能不是这个类别，如CJ路线是在Vehicle 类中，这是可以修改的），在放置物体的模式下，用鼠标在公路上单击，会出现两个用线连起来的蓝色的立体箭头（如图3-29所示）。
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两个蓝色箭头间的连线如果是蓝白闪烁的话，说明Car Spawner是有效的；如果连线是红色，说明Car Spawner无效，即游戏中不起作用（需要用移动功能来调整）。两个箭头中的区间就是所生成的汽车行驶路线，它是可以拉长的。

选择其中一个箭头，再按Mode窗口中的移动物体按钮，这时可以用鼠标拖动箭头以改变连线（汽车路径）的长度和位置。

用鼠标选择箭头，并单击右键，会弹出属性对话框，在里面可以设置生成汽车的间隔时间和平均速度。

注：用鼠标右键单击所选物体，可以弹出该物体的相关属性对话框。

注：Object Selector对话框中的物体所属类别对于不同路线可能是不一样的，这是在编辑路线的.ref文件时所规定的

注：如果铁轨或公路与地面有一定高度的话，在选中铁轨和公路时按“Y”键，可以自动在铁轨和公路下生成带有坡度的路基。

2.4 添加站台
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现在我们的路线中有两个简易的车站（只有两条股道），如果希望在游戏中按“F6”键或者在编辑任务时可以看到站台名称，我们还需要为每条股道添加站台。

把摄像机视角移动到图3-30所示位置，在Object Selector对话框中选择<Interactive Objects>类中的Platform（站台），用鼠标放置在左边的侧线上，这时出现两个由线连起来的绿色箭头，和Car Spawner一样，箭头间的连线长度（表示站台长度）和位置可以调节。图3-31。
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大家请留意箭头间连线向右拐了一下，代表站台位于轨道的右侧（从左下朝右上看），而我们的站台要建在左侧，所以要进行以下修改。选择一个绿色箭头并单击右键，这时会弹出站台的属性对话框（图3-32）。对话框的中间有两个复选框“Left side”和“Right side”，将这两个选项进行切换，就可以改变站台的朝向。如果两个复选框同时选择，说明该轨道的两侧都有站台。另外，对话框的上方可以设置车站名称（Station name）和站台名称（Secondary (platform) name），这里的站台名称就是游戏中按“F6”键或在编辑任务时看到的站台名称。

注：这里的站台只是一个标记（将轨道的某一段标记为站台区间，而不是我们所看到的实际的站台，实际站台是当作静态物体被放置的。

2.5 修改地形高度（制作山坡和湖泊）

前面介绍铺设公路或铁路的时候按“Y”键，可以生成带有坡度的路基，也就是说铁路和公路下的地形被抬起来了，那么，如何修改普通地面的地形高度呢（如：生成山坡、洼地、湖泊等）？下面就简单介绍一下。
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    1. 在我们的路线中找一处平坦的地面。单击Mode窗口中的（修改地形高度）按钮，用鼠标（指针形状为一个圆圈加一个点）在地面上拖出一个红色的矩形框，如图3-33所示。
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在数字键盘上按“8”和“2”键（结合End键可以微调），可以对所选地形进行升高和降低，或者单击鼠标右键，选择菜单中的“Set Height…”命令，可以输入升高的高度，这里我们输入50（单位：米）。然后会看到所选地面已经升高了，接着按下“J”键进行重计算，您会发现升高后的地形更加真实了（如图3-34所示）。

在升高或降低地形之前，可以预先设置一下参数，即Terrain窗口中的embankment、width、cutting，已得到不同的地形效果，具体参数含义请参阅第10页中3.Terrain中的解释（1.2 工具窗口）。

2. 我们还可以用类似的方法制作湖泊。在平地上拖出红色矩形框后，按数字键盘上的“2”键，直到生成一块洼地（图3-35）。
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单击Mode窗口中的（修改地形材质）按钮，这时，地面上会出现黑色的小方格和蓝色的大方格（图3-36），一个蓝色方格就是一个Terrain tile（地形方块），而黑色的小方格是用来修改地形材质用的。
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现在的洼地位于四个黑色方格内，用鼠标单击其中一个方格，会在里面出现一个红色的线框，在其中单击右键，选择菜单中的“Toggle water”命令，这时，当前黑色方格内的洼地部分就充满了水。接着依次对其他三个方格进行相同的操作，最终使洼地变成湖泊（见图3-37）。

    另外还可以设置湖泊水面低于地面的高度。在出现红色线框的时候单击鼠标右键，选择菜单中的“Set tile water height”命令，在依次弹出的四个对话框中输入水面低于地面高度（单位：米）。图3-38是设为-10米时的效果。

2.6 修改地形材质

　　现在，我们的路线周围还是一望无际的绿草地，显得太单调了，而在其它路线中，我们可以看到路边有农田、沙地、岩石等不同的地表，这是通过修改地形的材质来实现的。
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1. 单击Mode窗口中的（修改地形材质）按钮，地面上会出现黑色的方框（这是修改材质的单位地形大小）。接着打开主窗口中的“Window”菜单，选择“Texture select”命令，会弹出Texture selector（材质选择器）窗口（如图3-39所示）。

在这个窗口中可以选择所需的材质，用于修改指定的地形。现在，当前窗口只有一种默认的材质，我们先来添加几种其它材质。

2. 我们的My Route路线中用到的所有材质是以ace格式存放在游戏目录中的“Routes\My Route\Terrtex”文件夹中的（其它路线也是一样的）。打开游戏目录中“Routes\Japan1\Terrtex”文件夹，将其中所有的ace文件复制到“Routes\My Route\Terrtex”文件夹中，这样我们就可以使用别的路线提供的材质了。
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3. 在Texture selector窗口中，选择菜单“Edit”（编辑）中的“Insert…”（插入）命令，在弹出的打开对话框中，选择JP1HalfUrban-Grass.ace、JP1QuartUrban-Grass.ace和JP1Urban.ace三个文件（按住Ctrl键可以选择多个文件）。确认退出后，Texture selector窗口中会增加相应的材质图片，而且每个材质都有一个编号，如图3-40所示。其中带有红色边框的材质是主窗口中当前选择的黑色方框中地形的材质，也就是说，修改地形材质时，每次只能对一个黑色方框内的地形进行操作。

接着就按下面的步骤对材质进行修改。

4. 在主窗口中的地面上选择一个黑色方框（用鼠标单击使其中出现红色方框），然后按“4”键，这时，所选黑色方框内的地形材质变成了Texture selector窗口中的4号材质，如图3-41所示。

    接着，分别对当前黑色方框的左上、上、右上、左、右、左下、下、右下这八个黑色方框设置3号、2号、3号、2号、2号、3号、2号、3号材质，这时，效果如图3-42所示。
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    5. 现在的材质看上去有点乱，我们可以对每个材质方框进行调整。当选中某一个黑色方框时，用鼠标在上面单击右键，在弹出的菜单中选择“Rotate”（旋转）命令，可以对当前方框内的材质进行90°、180°和270°的顺时针旋转操作。我们用这个操作适当地对几个黑色方框内的材质进行旋转调整，调整后的效果如图3-43所示。
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2.7 添加接触网

因为我们建造的路线是电气化铁路，所以还要为其添加接触网及电杆。使用主窗口中“Auto-placement”菜单中的“Add gantries”和“Remove gantries”命令，可以为指定轨道添加和删除接触网及电杆。有关添加接触网的具体方法，请参阅Blue sky 编写的《架设接触网电杆》一文。
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到此，建造MSTS路线的基本方法就介绍的差不多了。因为MSTS功能强大，且路线中的物体种类很多，鉴于本人的能力有限，教程中没有涵盖所有的内容，只不过是想尽可能帮助大家入门。教程中相关术语或内容有什么错误，欢迎大家指正，并提出修改意见。

希望大家尽快投入到虚拟铁路的建设队伍中，为做出真正属于中国的路线而努力！
图1-1





图2-1





图2-2





图2-3





图2-4





图2-5





图2-6





图2-7





图2-8





图2-9





� EMBED Photoshop.Image.6 \s ���





图2-10





图3-26





图3-1





图3-25





图3-2





� EMBED Photoshop.Image.6 \s ���





图3-3





图3-5





图3-6





图3-4





图3-7





� EMBED Photoshop.Image.6 \s ���





� EMBED Photoshop.Image.6 \s ���





� EMBED Photoshop.Image.6 \s ���





� EMBED Photoshop.Image.6 \s ���





� EMBED Photoshop.Image.6 \s ���





� EMBED Photoshop.Image.6 \s ���





� EMBED Photoshop.Image.6 \s ���





� EMBED Photoshop.Image.6 \s ���





� EMBED Photoshop.Image.6 \s ���





图3-9





图3-10





图3-11





图3-12





图3-13





图3-14





图3-15





按T键





图3-16





图3-17





图3-18





图3-19





图3-20





� EMBED Photoshop.Image.6 \s ���





图3-21





图3-24





图3-22





� EMBED Photoshop.Image.6 \s ���





图3-23





图3-27





图3-28





图3-29





图3-30





侧线





图3-31





图3-32





� EMBED Photoshop.Image.6 \s ���





图3-33





图3-34





� EMBED Photoshop.Image.6 \s ���





图3-35





图3-36





图3-37





图3-37





图3-38





� EMBED Photoshop.Image.6 \s ���





图3-39





图3-40





图3-41





图3-42





图3-36





起点





终点





侧线





正线





侧线





正线





图3-8








- 26 -

[image: image71.jpg]


[image: image72.jpg]


[image: image73.jpg]


[image: image74.jpg]


[image: image75.jpg]


[image: image76.jpg]


[image: image77.jpg]


_1098899841.psd

_1098899895.psd

_1099166740.psd

_1099508418.psd

_1100119150.psd

_1099251107.psd

_1098981231.psd

_1098899867.psd

_1098899881.psd

_1098899859.psd

_1098898488.unknown

_1098899812.psd

_1098899473.unknown

_1098638636.psd

_1097500636.psd

